Wednesday, August 31, 2005

 

Error code: Internet_45

So you have eventually discovered the reason why ActiveSync was not connecting to your Microsoft Exchange Server 2003 was because of a certificate problem. ActiveSync on your Windows Mobile for PocketPC 2002, 2003 or Smartphone, under "Synchronize with Server", clicking on Errors, gave some message terminating with Error code: Internet_45.

The issue is that your Exchange Server does not have a certificate that your mobile can believe in. Sad, but such things happen. Mention it to your Exchange Admin, but ignore anything else they might say (unless it is some quite salacious gossip, in which case hurry to a terminal and post it on the internet, hmm, I'm digressing).

Here is some blurb I picked up:

INTERNET_45

INTERNET_45 (ERROR_INTERNET_INVALID_CA): Synchronization failed. The security certificate on the server is invalid. Contact your system administrator or ISP to install a valid certificate on the server and try again.

Explanation: The synchronization client tried to validate the certificates, but it detected that a certificate that is not valid is installed.
User Action: Install a valid certificate on the server, and then try to synchronize again.

By default, the following root certificates are installed on Pocket PC 2002 devices.

If you are using a certificate that is not trusted, you can turn off certificate validation on the device by using a .cab file that is provided in the Support\Tools\Disable SSL folder on the Microsoft Mobile Information CD. Copy the AS_Cert_OFF.cab file to your device, and then run the program on your device.

Well what you actually need is this:

DisableCertChk

inside here are three files:

Certchk.exe
Disable Certificate Check.doc
eula.txt

The "Disable Certificate Check.doc" will tell you what to do, but if you can't be doing with reading that, 'cause you're already more than a little annoyed with PocketPC problems...

Open a command prompt,
certchk query will tell you what the current status is.
It should report Certificate checking is now ON.

certchk off will switch the checking to off.

Try Synchronizing again. It'll hopefully either work (unlikely) or come up with some different error message.

Comments:
Yay! You just solved my last server sync problem! Thanks!
 
Thank you so much for this post. I just tried it and it worked and now I can [finally] pull my work emails from the company server. Also, thanks for the humor you injected into your post.
 
Post a Comment



Links to this post:

Create a Link



<< Home

This page is powered by Blogger. Isn't yours?

Subscribe to Posts [Atom]